[Title]

[Subtitle]

MASTER THESIS

[FIRSTNAME] [LASTNAME]

[Month] [Year]

Thesis supervisors:
Prof. Dr. Jacques PASQUIER–ROCHA & Dr. Patrik FUHRER
Software Engineering Group

[Other supervisors]

[Logo]
“Productivity is never an accident. It is always the result of a commitment to excellence, intelligent planning, and focused effort.”

*Paul J. Meyer*

American entrepreneur and author
Abstract


Keywords: Template, Tutorial, Master Thesis, Word 2007
Foreword

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Proin in diam. Nam
ignissim facilisis lorem…

Acknowledgments

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Proin in diam. Nam
ignissim facilisis lorem…

Notations and Conventions

- **Bold** and *italic* are used for emphasis and to signify the first use of a term.
- *Courier New* is used for web addresses.
- **Code** is used for all the source codes and generally for anything that would be
typed literally when programming, including *keywords, constants, method
names, variables, class names*, and *interface names*.
- **AUTHOR** names are formatted in small capitals.
- The present report is divided in *chapters*. Chapters are broken down into
*sections*.
- Where necessary, sections are further broken down into *subsections* and
subsections may contain some *paragraphs*.
- **Figures, Tables** and **Listings** are numbered inside a chapter. For example, a
reference to *Figure j* of chapter *i* is noted *Figure i.j*.
- **Author references** [Mel04] as well as **web references** [Sof08] (note the *italic*
style) are tagged inside square brackets.
- As a respect to both genders, *he* and *she* are used interchangeably in this
document.
- Source code is displayed as follows:

```java
public class HelloWorld {
    public static void main(String[] args) {
        System.out.println("Hello world!");
    }
}
```

- Finally, useful hints are highlighted as shown below:

```
Hints provide complementary information in the corresponding section.
```
About This Documentation

This documentation is based on a template created by Pedro De ALMEIDA and Patrik FUHRER (Software Engineering Group, University of Fribourg, Switzerland). Citations and bibliography references are formatted through a XSL stylesheet, tailor-made for the purposes of the current template.

Both resources are open source and freely available under the Creative Commons Attribution 3.0 License [Cre08] from:

- http://diuf.unifr.ch/softeng/student-projects/templates/softeng_en_msword.docx
- http://diuf.unifr.ch/softeng/student-projects/templates/soften_en_msword_bib.xsl
Table of Contents

1 Introduction .................................................................................................................. 1
  1.1 Template purposes ................................................................................................. 1
  1.2 How to use this template? ...................................................................................... 1

Part I. Template Usage 2
2 Using this Template ......................................................................................................... 3
  2.1 Headings .................................................................................................................. 3
    2.1.1 Shortcuts ........................................................................................................... 4
  2.2 Table of contents (TOC) .......................................................................................... 4
    2.2.1 Main TOCs ......................................................................................................... 4
    2.2.2 Chapter TOCs .................................................................................................... 4
  2.3 Illustrations .............................................................................................................. 5
    2.3.1 Figures .............................................................................................................. 5
    2.3.2 Tables ............................................................................................................... 5
    2.3.3 Captions ........................................................................................................... 5
  2.4 Index ....................................................................................................................... 6
    2.4.1 Index entries .................................................................................................... 6
  2.5 Fields ....................................................................................................................... 8
    2.5.1 Insert a Field .................................................................................................... 8
    2.5.2 Edit a Field ...................................................................................................... 8
    2.5.3 Update Fields .................................................................................................. 8
  2.6 Bookmarks .............................................................................................................. 9
    2.6.1 Add a bookmark ............................................................................................... 9

3 References ................................................................................................................... 10
  3.1 Formatting References ............................................................................................ 10
  3.2 Distinguishing references ....................................................................................... 11

4 Terms of Use .................................................................................................................. 12
  4.1 Authors .................................................................................................................... 12
  4.2 License ..................................................................................................................... 12

Part II. Appendix 14
A Source Code ................................................................................................................. 15
B Project Website ............................................................................................................. 16
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software Engineering Group</td>
<td>16</td>
</tr>
<tr>
<td>Master Project</td>
<td>16</td>
</tr>
<tr>
<td>CD-ROM</td>
<td>17</td>
</tr>
<tr>
<td>References</td>
<td>18</td>
</tr>
<tr>
<td>Referenced Web Resources</td>
<td>19</td>
</tr>
<tr>
<td>Index</td>
<td>20</td>
</tr>
</tbody>
</table>
List of Figures

Figure 2.1 The Table of Contents group of the References tab ........................................ 4
Figure 2.2 A figure with an associated caption ........................................................................ 5
Figure 2.3 The Captions group from the References tab .......................................................... 6
Figure 2.4 The Index group from the References tab ................................................................. 6
Figure 2.5 The Links group from the Insert tab ....................................................................... 7
Figure 2.6 The Text group of the Insert tab ................................................................................ 8
Figure 2.7 The Links group of the Insert tab .......................................................................... 9
Figure 3.1 The Citations & Bibliography group on the References tab .................................. 11
Figure 3.2 The edition window for references with language selection ............................... 11
Figure A.1 The HelloWorld class ........................................................................................... 15
Figure A.2 The Windows PowerShell command line .............................................................. 15
Figure B.1 The project page of my Master Thesis ................................................................. 16
List of Tables

Table 2.1 An example of a formatted table ................................................................. 5
List of Source Code

Listing A.1 *The HelloWorld class* ................................................................. 15
1 Introduction

1.1 Template purposes

This template has been created for official documents purposes like thesis or other scientific reports. Feel free to use this template as long as you respect the Terms of Use described in Section 4.

1.2 How to use this template?

The next chapters will introduce the main aspects that you should know about this template. We encourage you to print this template before you begin to write your document.

“Rien ne se perd, rien ne se crée, tout se transforme”.

Antoine-Laurent de Lavoisier
French intellectual and chemist, 1743-1794
Part I.

Template Usage
“Now is the time for the Model Driven Architecture.”

Richard Soley in [Ric00]
Chairman and CEO of the Object Management Group (OMG)

2.1  Headings

In order to build Table of contents (TOC), it is recommended to mark your headings by choosing the corresponding level style ([1] H1, [1] H2, [1] H3, [1] H4).
2.1.1 **Shortcuts**

You can quickly mark a heading by using the keyboard shortcut `CTRL + <number>` where `<number>` defines the level of the targeted heading. For example, pressing `CTRL + 2` will mark the current paragraph as a heading of level 2.

2.2 **Table of contents (TOC)**

A table of contents is a reader's map. It provides an overview of what is in the document and helps readers find a particular section quickly.

A TOC may be a simple list of chapter titles, or it can include several heading or outline levels.

2.2.1 **Main TOCs**

In this document, main TOCs are used to build the “Table of Contents”, “List of Figures”, “List of Tables” and “List of Source Code”. If you have correctly marked your heading, you will be able to insert a table of contents (TOC).

1. Click where you want to insert the table of contents, usually at the beginning of a document.
2. On the References tab, in the Table of Contents group, click Table of Contents, and then click the table of contents style that you want.

Figure 2.1 *The Table of Contents group of the References tab*

*If you want to specify more options — for example, how many heading levels to show — click Insert Table of Contents to open the Table of Contents dialog box.*

2.2.2 **Chapter TOCs**

In order to include a table of contents of the current chapter only, create a field with the following content:

```
{ TOC \o "2-3" \b Chapter2 \t "[1] H2;1;[1] H3;2" }
```

*Code 2.1 The field value for a chapter TOC*
The entries of the TOC will be built from the headings retrieved within the bookmark \b Chapter2. Take a look into section 2.6 to learn more about bookmarks.

2.3 Illustrations

2.3.1 Figures

Figures will be formatted with the [2] Figure style. In order to build the List of Figures TOC, you will have to assign a caption to each one. See section 2.3.3 for more information about Captions.

![Figure 2.2 A figure with an associated caption](image)

2.3.2 Tables

Table formatting is done by applying the [2] Table - Header on the header cells of your table and [2] Table - Contents on the other table cells. Table captions are handled in the same way as figure Captions, described in section 2.3.3.

<table>
<thead>
<tr>
<th>Column 1</th>
<th>Column 2</th>
<th>Column 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>8</td>
<td>9</td>
</tr>
</tbody>
</table>

Table 2.1 An example of a formatted table

2.3.3 Captions

A caption is a numbered label, such as Figure 2.2 A figure with an associated caption, that you can add to a figure, a table, an equation, or another object.

Add a caption

1. Select the object (table, equation, figure, or another object) that you want to add a caption to.
2. On the References tab, in the Captions group, click Insert Caption.
3. In the Label list, select the label that best describes the object, such as a picture or equation. If the list doesn't provide the correct label, click New Label, type the new label in the Label box, and then click OK.

4. Type any text, including punctuation that you want to appear after the label.

5. Select any other options you want.

Add a caption with the current chapter number

If you want to include the current chapter number into the caption, you have to use the following field:

```
{ STYLEREF "[1] H1" \s }
```

**Code 2.2 The field value for the current chapter number**

2.4 Index

An index lists the terms and topics that are discussed in a document, along with the pages that they appear on. To create an index, you mark the index entries by providing the name of the main entry and the cross-reference in your document, and then you build the index.

2.4.1 Index entries

Mark words or phrases

1. To use existing text as an index entry, select the text. To enter your own text as an index entry, click where you want to insert the index entry.

2. On the References tab, in the Index group, click Mark Entry.
3. To create the main index entry that uses your own text, type or edit the text in the Main entry box.

4. If you want, you can customize the entry by creating a subentry (subentry: An index entry that falls under a more general heading. For example, the index entry "planets" could have the subentries "Mars" and "Venus."), a third-level entry, or a cross-reference to another entry:
   - To create a subentry, type the text in the Subentry box.
   - To include a third-level entry, type the subentry text followed by a colon (:), and then type the text of the third-level entry.
   - To create a cross-reference to another entry, click Cross-reference under Options, and then type the text for the other entry in the box.
   - To format the page numbers that will appear in the index, select the Bold check box or the Italic check box below Page number format.
   - To format the text for the index, select the text in the Main entry or Subentry box, right-click, and then click Font. Select the formatting options that you want to use.
   - To mark the index entry, click Mark. To mark all occurrences of this text in the document, click Mark All.
   - To mark additional index entries, select the text, click in the Mark Index Entry dialog box, and then repeat step 3 through step 6.

Mark words or phrases for text that spans a range of pages

1. Select the range of text that you want the index entry to refer to.

2. On the Insert tab, in the Links group, click Bookmark.

3. In the Bookmark name box, type a name, and then click Add.

4. In the document, click at the end of the text that you marked with a bookmark.

5. On the References tab, in the Index group, click Mark Entry.

6. In the Main entry box, type the index entry for the marked text.
   - To format the page numbers that will appear in the index, select the Bold check box or the Italic check box below Page number format.
   - To format the text for the index, select the text in the Main entry or Subentry box, right-click, and then click Font. Select the formatting options that you want to use.

4. Under Options, click Page range.
5. In the **Bookmark** box, type or select the bookmark name that you typed in step 3, and then click Mark.

### 2.5 Fields

Fields are used as placeholders for data that might change in a document and for creating form letters and labels in mail-merge documents. These kinds of fields are also called field codes, and they are different from the type of fields that are used to enter information, such as on a form.

#### 2.5.1 Insert a Field

1. Click where you want to insert a field.
2. On the Insert tab, in the Text group, click Quick Parts, and then click Field.
3. In the Categories list, select a category.
4. In the Field names list, select a field name.
5. Select any properties or options that you want.

   *If you know the field code for the field that you want to insert, you can also type it directly in your document. First press `CTRL+F9`, and then type the code within the brackets.*

#### 2.5.2 Edit a Field

1. Right-click in the field, and then click Edit Field.

   *For some fields, you must display the field code to edit the field. To do this, click the field, and then press `SHIFT+F9`. Or, to display all the field codes in the document, press `ALT+F9`.*

2. Change the field properties and options. For information about the properties and options available for a particular field, search on the field name in Help.

#### 2.5.3 Update Fields

1. By default, **Word** automatically updates fields when a document is opened. That way, information stays up to date. There are situations where you might not want
this to happen, however. For example, you may want the date in the header to reflect a particular date rather than automatically updating to the current date every time the document is opened.

2. Fields can also be updated by right-clicking a field and then clicking **Update Field** or by clicking in a field and then pressing F9.

---

### 2.6 Bookmarks

A bookmark identifies a location or a selection of text that you name and identify for future reference. For example, you might use a bookmark to identify text that you want to revise at a later time. Instead of scrolling through the document to locate the text, you can go to it by using the **Bookmark** dialog box.

You can also add cross-references to bookmarks. For example, after you insert a bookmark in a document, you can refer to that bookmark from other places in the text by creating cross-references to the bookmark.

#### 2.6.1 Add a bookmark

1. Select the text or item to which you want to assign a bookmark, or click where you want to insert a bookmark.

2. On the Insert tab, in the Links group, click **Bookmark**.

---

To manually update all the fields in the main body of a document, press `CTRL+A` and then press F9. Fields in headers, footers, or text boxes must be updated separately. Click within the header, footer, or text box, press `CTRL+A` and then press F9.

---

To display the bookmarks brackets:

1. Click the Microsoft Office Button, and then click **Word Options**.
2. Click **Advanced**, and then select the **Show bookmarks** check box under **Show document content**.
3. Click **OK**.
3 References

3.1 Formatting References

References are formatted through an XSL stylesheet. If you wish to use the tailor-made [Alm08] stylesheet to format your references, follow these steps:

1. Copy the file MasterThesis.xsl to the following directory:
   
   ```
   » <Program Files>\Microsoft Office\Office12\Bibliography\Style
   ```

2. Restart Word and check that the MasterThesis option is available in the Style box of the Citations & Bibliography group on the References tab (see Figure 3.1).

3. Select the MasterThesis option and refresh (F9) your references to apply the MasterThesis formatting.

3.2 Distinguishing references

“As a rule, software systems do not work well until they have been used, and have failed repeatedly, in real applications.”

David Lorge Parnas
Canadian professor and pioneer of Software Engineering
3.2 Distinguishing references

Word 2007 is not able to distinguish references in order to separate author and web references for example. Nevertheless, references can be filtered using the language attribute available in the reference edition window. This will allow producing different views of the references list on the base of their language.

If you want to build a list from all your English (U.S.) references, create a BIBLIOGRAPHY field and specify the language code that will be used to filter references:

```
{ BIBLIOGRAPHY \l 1033 \f 1033 }
```

For more information about the BIBLIOGRAPHY field, take a look at:

For a complete list of language codes, take a look at:

Take a look at the end of this document to see how references have been filtered to create two different lists of authors and web references.
4 Terms of Use

| 4.1 | Authors .................................................................................................................................................. 12 |
| 4.2 | License ............................................................................................................................................... 12 |

“Rules make the learner’s path long, examples make it short and successful.”

Seneca
Roman rhetorician and writer, mid-1st century AD

4.1 Authors

This template has been created by Pedro De Almeida from a base template developed by Patrik Fuhrer (Software Engineering Group, University of Fribourg, Switzerland).

4.2 License

This template is licensed under a Creative Commons Attribution License. This means you may use it for any purpose, and make any changes you like as long as you include a reference to the authors of this template, like:

This documentation is based on a template created by Pedro De Almeida and Patrik Fuhrer (Software Engineering Group, University of Fribourg, Switzerland). Citations and bibliography references are formatted through a XSL stylesheet, tailor-made for the purposes of this thesis.

Both resources are open source and freely available under the Creative Commons Attribution 3.0 License [Cre08] from:

- http://diuf.unifr.ch/softeng/student-projects/templates/softeng_en_msword.docx
- http://diuf.unifr.ch/softeng/student-projects/templates/soften_en_msword_bib.xsl
Part II.

Appendix
A

Source Code

```java
public class HelloWorld {
    /**
     * @param args
     */
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        System.out.println("Hello world!");
    }
}
```

Listing A.1 The HelloWorld class

Figure A.3 The Windows PowerShell command line
Software Engineering Group

- http://diuf.unifr.ch/softeng/

Master Project

- http://diuf.unifr.ch/softeng/student-projects/completed/dealmeida/

Figure B.1 The project page of my Master Thesis


Referenced Web Resources


[Cre08]  **Creative Commons.** *Attribution-Noncommercial-Share Alike 3.0 Unported.* [http://creativecommons.org/licenses/by-nc-sa/3.0/](http://creativecommons.org/licenses/by-nc-sa/3.0/) [Accessed Decembre 17, 2008].
## Index

### B
- Bibliography, 10
- Bookmark, 5, 9

### C
- Caption, 5, 6
- Chapter TOC, 4
- Citation, 10
- Cross-reference, 9

### F
- Field, 8
- Figure, 5

### I
- Index, 6
- Index Entry, 6

### R
- References, 10

### S
- stylesheet, 10

### T
- Table, 5
- Table of contents, 3
  - TOC See Table of contents

### X
- XSL, 10